Upload via GUI. current results ingestion doesn't work


Is there any possibility of upload results (from Nmap, Nessus, etc) from the Web UI instead console? I get this message CSV has the wrong headers. Header must be present. Expected headers: cwe, description, name, ref, resolution.

I have recently used the CLI as a test on a virtual machine. The current provision is on a server and I can only access the GUI.

I appreciate any feedback.



Hi Seb,

Sure! You can upload certain reports from the WebUI, more info here: https://github.com/infobyte/faraday/wiki/Upload-Report#through-the-web-ui

Those headers are obligatory to have in the .csv you’re trying to upload, more info here: https://github.com/infobyte/faraday/wiki/CSV-Importer

If you encounter any other issues, please post them here.

You can also get a demo of our commercial version if you’re interested. Contact us through faradaysec.com or write to sales@infobytesec.com .

Hope this helped! Have a great day.



Thanks Sencinas,

Yeah we have just signed up for a product to use Faraday. Im just about uploading my scans. But I dont think its been fully up and running. I will collaborate with IT to sort it thanks.



Hi Sencinas,
So i have my Faraday corporate up and running and using the Web GUI as its been provision to work. I have create a work-space and try to upload a .nessus scan result. I have tried this over 10 time and recreating a new work space again and i get the same result of Not enough data to generate summarized report yet. We have just paid for this licence and hoping Faraday will work well with us. Please let me know if there some thing else i need to have done as i didn’t have this issue using the community version.